Needing help with 7mgte electrical issues!!!

ktothec13

New Member
Sep 21, 2014
4
0
0
florida
Need help with 7mgte electrical issues, my 7mgte randomly runs rich burying the wideband to where it just shows dashes, it wont idle without you giving it light throttle and when you give it more then light throttle itll shut off, not like bad maf at around 2500rpm, it's around 1100ish maybe a little more, it just tries to die like you turn the key off, but if you quickly let off the petal it wont completely stall. If you pull the afm signal wire loose it'll run better, it runs like it normally would without the afm hooked up which is better then when its acting up like this, i men its so bad you cant drive over 10-15mph! I have tried different known working afms with no change whatsoever, disconnect tps, only makes a difference in a slight idle change, im at a loss, itll work great for weeks then slowly start acting up worse and worse til its undriveable, and other times itll just randomly instantly go to the point of undriveability.
 

ktothec13

New Member
Sep 21, 2014
4
0
0
florida
Yea I haven't been able to figure it out! It can run great at times then slowly get worse, or it'll just get bad instantly, there is no consistency to it, maybe some bad wires in the harness?
 

suprarx7nut

YotaMD.com author
Nov 10, 2006
3,810
0
36
Arizona
www.supramania.com
jetjock;2062922 said:
You did all that and are still at a loss?

ktothec13;2063590 said:
Yea I haven't been able to figure it out! It can run great at times then slowly get worse, or it'll just get bad instantly, there is no consistency to it, maybe some bad wires in the harness?

Lol.

Woosh.

ktothec: You need to start with some basics. Unplugging random components doesn't help you figure anything out. There's a process to figuring this stuff out. Check for codes being step 1. ;)
 

ktothec13

New Member
Sep 21, 2014
4
0
0
florida
Is there a write up anywhere on how to wire up the check engine light? lol Mine is in a 76 Celica so I don't have the check engine light, but yea I know I really need to get it wired in and check for codes!