Blinker voltage drop

kotu100

Active Member
Nov 23, 2006
1,899
0
36
Easton, Ma
Been trying to trouble shoot this for a couple weeks now unsuccessfully.

When i turn my blinker on i can hear my AEM fuel pump fluctuating with the blinker but it doesn't happen with the hazards. Also the parking brake light on the dash dims with the blinker but not the hazards.

I've checked the voltage drop for the blinker system but can't seem to find anything wrong. I know the hazard switch is what tells the system whether to get power from the 7.5A blinker fuse or the 15A hazard fuse.

Any ideas?
 

Nick M

Black Rifles Matter
Sep 9, 2005
8,840
21
38
U.S.
www.ebay.com
What is your battery voltage when this is going on? Have the car off and turned off the blinkers on and test. You should have a minimal drop. An overpriced but damn useful tool like the SPX OTC battery tester might say your 540 CCA battery is actually only good for 410 CCA these days. Which will still start the car.
 

kotu100

Active Member
Nov 23, 2006
1,899
0
36
Easton, Ma
Just check it and battery volts with key off only jumps from 12.5 to 12.48-12.49 with the blinker on and the fuel pump doesn't fluctuate.
With car running volts is jumping from 14.5-15 with the blinker on. This is with a new carquest alt.


I have no problem starting the car, my issue lies in the voltage drop causing my fuel pump and ecu voltage to fluctuate.
Don't really see what CCA has to do with this.
 

kotu100

Active Member
Nov 23, 2006
1,899
0
36
Easton, Ma
MK3Supra17;2079884 said:
Check your fuel pump ground while its running. I bet its bad and its trying to ground through another circuit.

Thanks for the suggestion. I actually rewired the ground for the fuel pump altogether to eliminate that possibility.

I'm pretty sure the issue is the alternator, it got better with a parts store replacement but the voltage still jumps when a load is put on the electrical system. I think I need to get a Bosch or upgraded DM alt.