Powered by Team Mondor
Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: Help! Supra doesn't run right

  1. #21
    90T
    3p141592654's Avatar
    Join Date
    Oct 2005
    Location
    Thousand Oaks, CA
    Posts
    3,644

    Default Re: Help! Supra doesn't run right

    Before you do that place a shield between the fan and the afm. These afms are sensitive to turbulence and that setup you have is pretty near worst case. Also. For now you can unplug the tps. It will run ok without it and remove one more uncertainty for now.

  2. #22
    Lurker
    Abe's 1987's Avatar
    Join Date
    Sep 2017
    Location
    Houston,TX
    Posts
    23

    Default Re: Help! Supra doesn't run right

    Trying to see if I can find an afm and tps for a good price. But the question I have is i already have the part number for the afm but I don't have for the tps. I'm getting conflicting numbers for the tps. I need the part number for the pre 89. I figured based on my ecu that my swap is a 86-88.
    2007 BMW 328i, daily driver
    1997 Chevrolet Camaro z28 6 speed, fun V8
    1987 Toyota Supra turbo 5 speed, new toy

  3. #23
    Lurker
    Abe's 1987's Avatar
    Join Date
    Sep 2017
    Location
    Houston,TX
    Posts
    23

    Default Re: Help! Supra doesn't run right

    Quote Originally Posted by 3p141592654 View Post
    Before you do that place a shield between the fan and the afm. These afms are sensitive to turbulence and that setup you have is pretty near worst case. Also. For now you can unplug the tps. It will run ok without it and remove one more uncertainty for now.
    Im going to do this tomorrow and see what happens.
    2007 BMW 328i, daily driver
    1997 Chevrolet Camaro z28 6 speed, fun V8
    1987 Toyota Supra turbo 5 speed, new toy

  4. #24
    Lurker
    Abe's 1987's Avatar
    Join Date
    Sep 2017
    Location
    Houston,TX
    Posts
    23

    Default Re: Help! Supra doesn't run right

    Ok so I bought a new tps and used afm on eBay just waiting for them to come in. I also bought some sheet metal to build a casing around the filter. Had to fix the steering column as the locking mechanism was jammed and the steering wheel was going all over the place. Found a few cut wires on the column which I'm fixing. It is most likely the horn and cruise wiring as they don't work. Will keep you guys updated.
    2007 BMW 328i, daily driver
    1997 Chevrolet Camaro z28 6 speed, fun V8
    1987 Toyota Supra turbo 5 speed, new toy

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •