Powered by Team Mondor
Page 2 of 6 FirstFirst 123456 LastLast
Results 11 to 20 of 59

Thread: Help! Supra doesn't run right

  1. #11
    Lurker
    Abe's 1987's Avatar
    Join Date
    Sep 2017
    Location
    Houston,TX
    Posts
    43

    Default Re: Help! Supra doesn't run right

    I check the afm as the tsrm says to with a multi meter and I got the ohms reading within specs. I also opened the ecu and everything looks to be good. When i get the supra started no check engine light. I jumped E1 with TE1 and the check engine light just blinks continuously none stop so i guessed that means no codes. At this point im stumped. I've have come to a point where I guess I just have to keep swapping parts out to find the issue. Problem is that is going to cost a pretty pennie.
    2007 BMW 328i, daily driver
    1997 Chevrolet Camaro z28 6 speed, fun V8
    1987 Toyota Supra turbo 5 speed, new toy

  2. #12
    Lurker
    Abe's 1987's Avatar
    Join Date
    Sep 2017
    Location
    Houston,TX
    Posts
    43

    Default Re: Help! Supra doesn't run right

    Only thing I haven't tested was fuel pressure but I don't think it would cause these issues would it? But yeah if anyone has some extra parts I could use to eliminate possible suspects aka (tps, iacv, afm, ecu, ect.....) to loan I'd be willing to pay shipping and ship it back as soon as I test it I'd appreciate it.
    2007 BMW 328i, daily driver
    1997 Chevrolet Camaro z28 6 speed, fun V8
    1987 Toyota Supra turbo 5 speed, new toy

  3. #13
    87T Supra
    plaaya69's Avatar
    Join Date
    Nov 2006
    Location
    Lake County, IL
    Posts
    797

    Default Re: Help! Supra doesn't run right

    When my AFM got destroyed along time ago (Because I used crc mass air flow sensor cleaner when it first came out and it had no warnings on the label like it does now "not to use in Toyota Supra Turbo") it would not go past 3k rpms. Usually also when the ISCV goes bad it will make the Supra idle at 3k rpms. I made a quick video of my turbo Supra running with the AFM unplugged and the symptoms it shows. Is this how yours is running?

    https://youtu.be/MQHoO1Pz3MI
    2004 Lexus GS300 - daily diver
    1987 Toyota Supra Turbo - burgundy exterior w/gray interior the summer driver.
    1987 Toyota Supra Turbo - parted put
    1987 Toyota Supra N/A - Sold

    Some Pictures.
    http://www.supramania.com/forums/showthread.php?t=81005


  4. #14
    Lurker
    Abe's 1987's Avatar
    Join Date
    Sep 2017
    Location
    Houston,TX
    Posts
    43

    Default Re: Help! Supra doesn't run right

    Here is two vids of the supra running. Hopefully this helps.
    https://m.youtube.com/watch?v=2Zf-RpcMDN8
    https://m.youtube.com/watch?v=itpl96_7WAg
    2007 BMW 328i, daily driver
    1997 Chevrolet Camaro z28 6 speed, fun V8
    1987 Toyota Supra turbo 5 speed, new toy

  5. #15
    Lurker
    Abe's 1987's Avatar
    Join Date
    Sep 2017
    Location
    Houston,TX
    Posts
    43

    Default Re: Help! Supra doesn't run right

    The things I do notice now since fixing a few of the problems the idle does now fluctuates between 1500 and 2000 rpms and now it wont rev past 2500 rpms. The started was tested good as its a new starter but as you can hear in the videos it has problems starting, not sure why it does that.
    2007 BMW 328i, daily driver
    1997 Chevrolet Camaro z28 6 speed, fun V8
    1987 Toyota Supra turbo 5 speed, new toy

  6. #16
    90T
    3p141592654's Avatar
    Join Date
    Oct 2005
    Location
    Thousand Oaks, CA
    Posts
    3,649

    Default Re: Help! Supra doesn't run right

    Has it ever run properly with the setup you have there? One thing I notice is the lack of a fan shroud right next to the AFM with an exposed filter which could be causing turbulence at the AFM. Try shielding the air filter from the fan with a piece of cardboard or sheet metal. Also make sure the honeycomb is still on the front of the AFM.

  7. #17
    90T
    3p141592654's Avatar
    Join Date
    Oct 2005
    Location
    Thousand Oaks, CA
    Posts
    3,649

    Default Re: Help! Supra doesn't run right

    The other thing I would check is the IDL signal, since it seemed to smooth out when you unplugged the TPS. Could be the trailing throttle fuel cut being acitvated because your IDL signal is not set correctly or the TPS is broken.

    This is the symptom of a maladjusted TPS.
    http://www.cygnusx1.net/Supra/Librar...ction=FI&P=125

    and this is how you check the IDL signal.
    http://www.cygnusx1.net/Supra/Librar...spx?S=FI&P=101

  8. #18
    Lurker
    Abe's 1987's Avatar
    Join Date
    Sep 2017
    Location
    Houston,TX
    Posts
    43

    Default Re: Help! Supra doesn't run right

    So it has been running like this since i bought the supra. Ive had it for coming up to two months. I will check all these in the morning.
    2007 BMW 328i, daily driver
    1997 Chevrolet Camaro z28 6 speed, fun V8
    1987 Toyota Supra turbo 5 speed, new toy

  9. #19
    Lurker
    Abe's 1987's Avatar
    Join Date
    Sep 2017
    Location
    Houston,TX
    Posts
    43

    Default Re: Help! Supra doesn't run right

    Ok so the honeycomb is on. I also decided to double check the ohms reading of the tps, iacv, and afm. So now the afm has no readings even though prior it was reading within specs. And I think based on my readings I has to also adjust the tps or it is bad as well . Iacv is still reading good.
    2007 BMW 328i, daily driver
    1997 Chevrolet Camaro z28 6 speed, fun V8
    1987 Toyota Supra turbo 5 speed, new toy

  10. #20
    Far From Maddening Crowds
    Piratetip's Avatar
    Join Date
    Dec 2005
    Location
    MKE, WI
    Posts
    859

    Default Re: Help! Supra doesn't run right

    Try a new or known working AFM.
    I rebuild / upgrade Supra Differentials - PM me for more information.

    1 Piece Driveshaft Information
    Critical Speed Calculator

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •