Powered by Team Mondor
Results 1 to 7 of 7

Thread: Oil smoke issue

  1. #1
    Junior Member

    Join Date
    Jul 2009
    Location
    Centerville, TN
    Posts
    127

    Default Oil smoke issue

    So my fresh engine had a few issues at first (too much boost because of wastegate linkage hitting IC pipe) but now runs strong, except that at about 500 miles it began smoking when backing of to a stop. Large cloud comes up and surrounds car. 7M GTE with minor mods--big intercooler, 3 inch driftmotion exhaust and down pipe, driftmotion modified oil pump, all new internals, and no smoke when first running 300 miles or so. Having someone follow me they say anytime I back off the throttle it smokes. About to change the oil so I will look for oil dilution, but AF gauge looks ok, so I'm thinking turbo seal? All ideas and diagnostic tricks most welcome.

  2. #2
    Junior Member

    Join Date
    Jul 2009
    Location
    Centerville, TN
    Posts
    127

    Default Re: Oil smoke issue

    I see many have looked at this post but no replies. I was very careful setting up valves (using big block chevy inner springs) and hand installed each valve seal. All pistons went in smoothly and ring gaps were aligned by the book. All new machine work and fitment dead on. Is it possible rings just have not seated yet? Did my usual breakin procedure after finding the boost issue and did not see any smoke thereafter until about the 500 miles mark. Any ideas most welcome.

  3. #3
    YotaMD.com author
    suprarx7nut's Avatar
    Join Date
    Nov 2006
    Location
    Arizona
    Posts
    3,700

    Default Re: Oil smoke issue

    Sounds like valve stem seals, but that would be odd if you just replaced them. I'd do a compression test or a leak-down test if you have the equipment.

    I've never had noticeable smoke after the initial start up of a rebuild on a 7M. How old is the turbo?

  4. #4
    Junior Member

    Join Date
    Jul 2009
    Location
    Centerville, TN
    Posts
    127

    Default Re: Oil smoke issue

    The turbo is original, but was rebuilt by a shop in Nashville called Auto Turbo. We have had some reports since they did the rebuild of some others being unhappy with their work, but the turbo had not been an issue prior to the engine overhaul. Is it possible the stuck wastegate linkage that was causing excess boost when first run may have damaged the turbo oil seal? We never let the boost get above 12psi. I will do a comp test and see if I can borrow a leak down tester. Thanks for your response. More soon.

  5. #5
    Lurker

    Join Date
    Aug 2016
    Location
    Camas wa
    Posts
    26

    Default Re: Oil smoke issue

    Sounds like valve issue to me too, seals or guides. Or even the stem, one might have had a nick on it and could have cut the seal.. Would be hard to believe though but a possibility


    Sent from my iPhone using Tapatalk

  6. #6
    Junior Member

    Join Date
    Jul 2009
    Location
    Centerville, TN
    Posts
    127

    Default Re: Oil smoke issue

    I personally built the head after having it done wrong the last time. I was quite careful about the seals so don't think that could be it, plus my experience is bad seals will show smoke when first fired up. Smoke only shows when snapping throttle shut and pulling up to a stop. Really still think it could be a PCV issue as this car has no PCV valve so max vacuum occurs at closed throttle. We have installed a catch can and tried several test ways of blocking off the system but no fix. No smoke upon accel or just cruising as far as we can tell. Still only have about 1000 miles on fresh rebuild.

    Thank you for your response Cp2295. All ideas most appreciated. Anyone using a PCV valve in this system? What type? Adjustable?

  7. #7
    fiend
    soup's Avatar
    Join Date
    Apr 2005
    Location
    Vic/Van
    Posts
    232

    Default Re: Oil smoke issue

    grey smoke?
    try adjusting your TPS :
    http://www.cygnusx1.net/Supra/Librar...spx?S=FI&P=100

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •