Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Suspiciously Slow JZA70

  1. #11
    Supramania Regular
    yhatzee89's Avatar
    Join Date
    Aug 2012
    Location
    Montgomery, AL
    Posts
    950

    Default Re: Suspiciously Slow JZA70

    Updated the first post
    Last edited by yhatzee89; June 20th, 2017 at 12:01 AM.
    "I got 99 problems but a 7M ain't one!"

    "MKIII Supras, turning men into mechanics since 86.5"

  2. #12
    Far From Maddening Crowds
    Piratetip's Avatar
    Join Date
    Dec 2005
    Location
    MKE, WI
    Posts
    776

    Default Re: Suspiciously Slow JZA70

    Cool digi dash.
    Retro.
    I rebuild / upgrade Supra Differentials - PM me for more information.

    1 Piece Driveshaft Information
    Critical Speed Calculator

  3. #13
    Lurker
    Join Date
    Apr 2017
    Location
    Md
    Posts
    11

    Default Re: Suspiciously Slow JZA70

    sweet!!! another jza70 limited to match mine!!!

  4. #14
    Supramania Regular
    yhatzee89's Avatar
    Join Date
    Aug 2012
    Location
    Montgomery, AL
    Posts
    950

    Default Re: Suspiciously Slow JZA70

    "Minor" setback yesterday, car didnt want to start, kept trying to die on the way home from work, and finally quit on me at a stop light. so now I gotta figure out what caused it to go from running like a dream to not even starting in a matter of a couple days
    Last edited by yhatzee89; August 6th, 2017 at 10:43 PM. Reason: P
    "I got 99 problems but a 7M ain't one!"

    "MKIII Supras, turning men into mechanics since 86.5"

  5. #15
    Supramania Regular
    yhatzee89's Avatar
    Join Date
    Aug 2012
    Location
    Montgomery, AL
    Posts
    950

    Default Re: Suspiciously Slow JZA70

    Update: 7/19/17
    Still not running, it's most likely the ECU or ignitor. But I've been doing a lot of other little projects in the meantime
    "I got 99 problems but a 7M ain't one!"

    "MKIII Supras, turning men into mechanics since 86.5"

  6. #16
    Supramania Regular
    yhatzee89's Avatar
    Join Date
    Aug 2012
    Location
    Montgomery, AL
    Posts
    950

    Default Re: Suspiciously Slow JZA70

    Update 8/6/17

    Finally got it up and running
    "I got 99 problems but a 7M ain't one!"

    "MKIII Supras, turning men into mechanics since 86.5"

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •