PDA

View Full Version : !! FC with 6.5 PSI !!



PorterzSupra
November 4th, 2005, 10:02 PM
I had a boost controller but I kept gettin FC right away so I took it off and now I still get FC now with stock boost WTF... im lookin into a few possibilitys, maybe have an innercooler leak or bad A/F box? Tell me what you guys think! Seems like I irritated the FC system now it just wants to come on all the time even after I put it back to stock... =(

gixxer750
November 4th, 2005, 10:20 PM
bet its a boost leak

GrimJack
November 5th, 2005, 02:18 AM
I'll second that bet.

Furthermore, I'll bet we won't get anyone betting against us, either.

PorterzSupra
November 5th, 2005, 07:24 AM
Could the boost leak be coming a little from my afternarket BOV? It does not let air out at idle but under a load it does before I let off. When I get the FC the check engine light comes on too then goes off.. I think the FC circut got irritated or somethin I cant really find a boost leak however my innercooler does have some damage.

boost fiend
November 5th, 2005, 12:03 PM
try patching the intercooler. that could be a start. try using another bov and see if the problem goes away.

GrimJack
November 5th, 2005, 02:13 PM
Try pressure testing the intake from the turbo to the engine. Find where the air hisses out and fix that.

FC at 6 psi = a damn big hole somewhere, we're not talking about a loose vacuum line here.

aye mate
November 5th, 2005, 02:33 PM
Be sure to check the IC piping >TB coupler.

Stanzaspeed
November 5th, 2005, 03:31 PM
mine was the gay plastic pipe that goes through the bumper from the ic. it had a nice big crack in it :biglaugh:

PorterzSupra
November 5th, 2005, 10:55 PM
FOUND IT!! The pipe from the bottom of the turbo was rotten now the car SCREAMS with no cut THANKS!! BTW, how does that work, why would a leak trigger FC? how does that work?

GrimJack
November 5th, 2005, 11:20 PM
Simple - a leak means that the turbo is sucking in more air to achieve the same pressure level. The AFM detects a little too much air, and WHAM, you have fuel cut.

PorterzSupra
November 6th, 2005, 09:20 AM
now I am running 15 PSI with no cut... YAY!!

GrimJack
November 6th, 2005, 07:05 PM
Hee hee... not quite the same car anymore, is it? :D

SP 7M
November 7th, 2005, 07:17 AM
I had a similar problem and I ended up having a vacuum leak.