PDA

View Full Version : SP61-GT wastegate issue



Techno Supra
January 14th, 2008, 02:27 PM
Ok, I got my car back this weekend and it seems the wastegate is stuck. Based on how much slower it builds boost and on Doc J's input it may be stuck partially open. The DDP sounds awful from the second I push on the throttle. I realize a ddp sounds like ass to begin with, which will be taken care of soon enough.

Does anyone have any recommendations on how to possibly free up the wastegate without having to pull the turbo and send it out to sound performance for work?

Additional note: The car had sat for a good year, but never had issues before and also built boost at 1000 less rpms with the restrictive elbow and hks DP.

Thanks in advance! I will try and get a sound clip up later today.

shaeff
January 14th, 2008, 03:14 PM
isn't the internal setup on the sp series almost identical to the ct26? if so, why not pull the exhaust off, pull the wastegate off, and see what exactly is stuck? it's most likely the actuator.

Techno Supra
January 14th, 2008, 06:24 PM
I'll give that a try. The setups do appear to be very similar.

MKIIINA
January 14th, 2008, 07:47 PM
its identical. its possible that its just partically suck open from lack of use. i had to reposition the arm once but i cant remember why.....

Poodles
January 14th, 2008, 09:57 PM
^^ resident expert on those turbos....good or bad LOL

MRSUPRA
January 15th, 2008, 05:12 AM
You might need to put a bend in the actuator rod. Make sure the rod is pushing straight. If there is any angle, it will malfunction.

Techno Supra
January 15th, 2008, 12:30 PM
Thanks for the input guys. Hopefully I'll have time to try and fix this thing today.

MKIIINA
January 15th, 2008, 02:32 PM
^^ resident expert on those turbos....good or bad LOL

just cuz i rebuilt 6 in a year doesnt make me an expert... just abusive of a less than dependable product.... been running my jt61gt w/o issue for over a year now without issue...... coincidence? i think not