What Next ?

Dozernl

New Member
Joined
Jul 4, 2018
Messages
7
Likes
0
#1
Hi folks I am not sure where to turn with my 1990 Supra turbo. I bought the car 2 years ago in the fall with a blown head gasket. Over the winter I rebuilt the 7M with all forged internals,head was polished and ported, BC 264 degree cams, arp hardware, HKS metal HG as well as new intercooler rebuilt ct 26 57 trim everything from DM. The car ran fine last summer in stock form. So winter past I changed to bosch 550 injectors in stock fuel rail did egr delete removed pcv piping and built a baffled catch can, walbro 255 fuel pump,aeromotive fpr, replaced seals in steering rack,installed ecumasters EMU. Now the car runs decent with a couple problem areas. I am having erratic idle one time it is 1800 next light might stall next light might be 800 so on so on. tried new tps and couple iac valves still same thing. Other problems are hard starting and when going uphill in 5th when trying to maintain highway speed you can feel it hitching and when u get on it hard say in third it will fall on its face like hitting fuel cut (running spring pressure on wastegate 6 psi) and sometimes will even backfire. So far what I have tried is new plugs new wires new coils increased dwell time on coils by 1ms did fuel pump mod. I have a wideband and my afr are good even when it is hitching which is why I was thinking ignition. Was thinking about getting the digital cps from Aaron at DM but was reading here that somebody had a sensor go after only 2 weeks has there been anymore feedback on this unit ? Was also thinking about driving coils with emu when I check the ignitor it is so hot you cannot keep your hand on it. Is that normal ? Any thoughts on these issues would be much appreciated. Thanks.

Dave
 

suprarx7nut

YotaMD.com author
Authorized Seller
Joined
Nov 10, 2006
Messages
3,875
Likes
12
Location
Arizona
#2
I don't suppose you can easily pull data logs? Zach with ECU Masters is on here. You may have best luck reaching out to him.
 

Dozernl

New Member
Joined
Jul 4, 2018
Messages
7
Likes
0
#3
Yea I could if I was at home but I am at work for next 2 weeks. That digital CPS upgrade was the last thing i could think of and was looking for a little feedback on it as well as any other ideas anybody has. Will give the data log a shot when I get back home. Thx for the reply.
 

plaaya69

87T Supra
Authorized Seller
Contributor
Joined
Nov 18, 2006
Messages
1,207
Likes
38
Location
Lake County, IL
#4
The igniter runs hot even with the OEM computer. I am not running the igniter with the ECU Masters standalone but I have it set up to run waste-spark with the standalone powering the factory 7mgte coils.

What spark plugs and gap are you running?

On the CPS, I would just do a rebuild for a remain unit with a lifetime warranty from rockauto unless you run a custom crank or cam gear trigger wheel for the hall effect sensor.
 

Dozernl

New Member
Joined
Jul 4, 2018
Messages
7
Likes
0
#5
Thx for the reply plaaya. Do you not like the digital cps option? I cant seem to make any progress with this car it has me stumped. :) Did your car work well with the EMU right away. I put a Haltech sport 2000 in my MK4 and never had a hitch.
 

plaaya69

87T Supra
Authorized Seller
Contributor
Joined
Nov 18, 2006
Messages
1,207
Likes
38
Location
Lake County, IL
#6
No problem Dave. Personally since the digital CPS a newer part, I wanted to wait a bit to see what others have to say about it but I know two people already had bad hall effect sensors on it so that is something to keep in mind. I also bought a remain CPS unit a few months before the digital CPS unit came out so I been sticking with that for now (especially since it has a lifetime warranty from A1-Cardone). I also made a brand new engine wiring harness and the CPS rewire kit from Yotaconnectors was used.

Honestly, no it did not go well right off the start. It was a combination of no information available and user error from me as well lol. For me timing was not synced properly, the fuel pump was not turning on (even with the PNP adapter) and just overall a poor base map for the 7mGTE. I was able to make some adjustments, upgrade the firmware and ECU Masters even updated their 7mGTE base map which is still not perfect but better than the one I originally had. When I took my Supra to Sound Performance, Larry helped me quite a bit to set everything up properly on the laptop and give me a base starting tune on the dyno which it made 366whp on pump gas then. Now it makes over 500whp on e85 and it idles like a kitten. With sequential injection I have noticed better gas mileage on pump gas (when I am driving it normal) even with 1200cc injectors and 264 cams.

I was told the ISC valve calibrates every time the key is turned on so wait a few seconds before starting right away on this standalone. Personally I would just either find a good local tuner in your area or find some places that will remote tune such as DriftMotion. Also the ECU Masters Facebook discussion group is full of helpful people that will look over your map that you currently have.
 
Last edited:

Dozernl

New Member
Joined
Jul 4, 2018
Messages
7
Likes
0
#7
Thats awesome I am looking for 400 to 425 rwhp but the best we have is 91 octane so I am limited that way. Yes that is what I have found with the EMU just not enough of them out there yet to get the support like you will have with a AEM or a Haltech. It was off a Aem site that I read about doing a firmware update to fix a problem I had with laptop disconnecting from emu every time I would start the car. I looked on ECUMASTERS forums but found nothing. Unfortunately I am not on facebook (1 of the few left in the world I think) LOL. If I sent you my map could you post it for me. I am also going to do a couple data logs along with it. The car is very close to working properly just needs a little tweaking runs along pretty good until u get on it hard and i doesn't like that (stumbles backfires falls on its face). The more load you add the worse it gets.
 

plaaya69

87T Supra
Authorized Seller
Contributor
Joined
Nov 18, 2006
Messages
1,207
Likes
38
Location
Lake County, IL
#8
I am not on Facebook either but I just been reading everyone else problems, solutions and projects in the public group. A few good 7mGTE ones in that group.

I had that issue as well when it would disconnect at first but with the firmware update I performed on the standalone, it does not do that anymore. What version are you running?
 

Charly Mr

New Member
Joined
Sep 13, 2018
Messages
3
Likes
1
#9
I completed the conversion from the stock CPS to an AEM EPM today, after I tried the DM digital CPS with unsuccessful results. I am running on an AEM EMS V2 and it crancked right up and running great after 2 months messing with stock CPS and the Digital CPS. 20180913_171927.jpg
 

suprarx7nut

YotaMD.com author
Authorized Seller
Joined
Nov 10, 2006
Messages
3,875
Likes
12
Location
Arizona
#11
Wow, very interesting! Hit us with the details! What's going on there? I'm sure it's only a matter of time before I need to deal with that damn CPS again. It'd be great to have a back up plan.