smokes grey, than goes away.

supra_man87

EL GUAPO
Authorized Seller
Joined
Nov 15, 2007
Messages
241
Location
So. Col.
Hey fellas. So 7mgte here. Just rebuilt. He pistons (ceramic top and coated sides.) So I just rebuilt it and started it up. Purred fine. Broke in the rings how my machinist told me. Rev car between 1500 and 2500 for 30 minutes. Took it out for a drive and car ran awesome. Drove to a friend's house and talked with him for a while. About 15-20 minutes later, car started to smoke. Revved the motor a little bit and it went away. Thinking it was oil getting past the journal on the turbo. Continued driving around, showing off the motor, eventually it would smoke again, I'd just rev it a bit and went away. Got home to inspect it a little better. Doesn't smell sweet. Doesn't feel moist. Feels dry and just smells like normal exhaust. Am not losing coolant so I'm pretty confident that it's just grey.

Side note, when everything was getting built, my turbo did sit with oil in it, in a bag that was soaked in oil. So maybe just burning off the residue. Car has maybe 3 hours of runtime. But other than that, no hesitation or anything. Car runs great. But I am worried about this smoke. Any help?

Ps, I did change my valve stem seals myself. Loaded them in a 10mm and felt them slide past the two grooves.
 

AbsoluteSpeed

Member
Authorized Seller
Joined
Aug 8, 2007
Messages
739
Location
Edmonton AB
Brand new engine? What kind of oil are you running?

Edit: and how exactly did you break it in?
 
Last edited:

supra_man87

EL GUAPO
Authorized Seller
Joined
Nov 15, 2007
Messages
241
Location
So. Col.
It originally had 183k and I just rebuilt it entirely. And I revved the car from 1500 to 2500, varying rpms, for 30 minutes. As per how my machinist told me.
 

Piratetip

Far From Maddening Crowds
Staff member
Super Moderator
Authorized Seller
Joined
Dec 30, 2005
Messages
1,969
Location
MKE, WI
It originally had 183k and I just rebuilt it entirely. And I revved the car from 1500 to 2500, varying rpms, for 30 minutes. As per how my machinist told me.
You revved the engine unloaded?
 

supra_man87

EL GUAPO
Authorized Seller
Joined
Nov 15, 2007
Messages
241
Location
So. Col.
I still am planning on taking the car on a couple of mountain roads. Just want to make sure I can get there and back.
 

AbsoluteSpeed

Member
Authorized Seller
Joined
Aug 8, 2007
Messages
739
Location
Edmonton AB