R154 Gurus needed!

s turbo 87

Accepting Donations
Joined
Apr 5, 2005
Messages
184
Location
Louisville, KY
I recently purchased all of the Marlin Crawler upgraded parts along with the Driftmotion 3-4 shift fork and a rebuild kit from suprastore.com.

I had a local shop rebuild the transmission and drove it for no more than 100 miles until a problem arose. I heard a loud squeal in 2nd gear and then in 3rd gear. When I came to a stop and tried to take off in 1st gear, the transmission made a loud grinding noise and kicked it out of gear. I was close to home and was able to limp it home in 2nd-4th gear, but there was a loud grinding noise while rolling in all of those gears as well. It didn't grind going into gear, just while it was in gear.

I took the transmission back to the shop and they told me that the Marlin Crawler 1st-2nd gear shift fork was too large and not made properly....which I find very, very hard to believe. They said that it was because the shift fork was too wide and it rubbed against 2nd gear, causing a lot of aluminum metal shavings to build up on the gears - which according to them is what caused my issue with the transmission kicking out of 1st gear and grinding in the other gears. They kept telling me that the transmission is "over shifting" second gear.

They said there's no chance that anything else can be wrong with the transmission and there's nothing that can be adjusted or installed incorrectly that would cause this and it is definitely the shift fork....I find this hard to believe because I have another R154 that has the IDENTICAL problem as the one they rebuilt but this one is 100% factory. I had removed the cases myself to find ZERO metal shavings in it although it was doing the same exact thing as the one I had them rebuild.

My question is what could be causing this problem? I find it odd that it happened to my stock one and then to a freshly rebuilt one with less than 100 miles on it.

Attached is a picture of the Marlin Crawler 1-2 shift fork and you can see where it has rubbed against 2nd gear.

Thanks in advance for any input and sorry if there is a blatantly obvious answer to this, transmissions are not my thing.
 

Attachments

s turbo 87

Accepting Donations
Joined
Apr 5, 2005
Messages
184
Location
Louisville, KY
Additionally, I was dogging the daylights out of my OEM transmission when this problem occurred but I hadn't started "banging" gears yet in the new one when it happened. I was shifting a bit harder than normal but nowhere near what I was doing with the stock one. Also, I have been using a stock shifter in both of these transmissions which came out of my old 87 supra that I dogged every time I drove the car and launched at 6500 rpm on slicks at the track numerous times and banged the hell out of every gear and never had any problems. It does have the Marlin Crawler shift bushings which is the only non-factory part about the shifter.

Thanks again.
 

Albert

Custom CT26, CT12a, CT20 upgrades
Authorized Seller
Joined
May 13, 2009
Messages
1,710
Location
Tempe, AZ
Absolutely not.


I just built one myself as didn't have a single issue.... The fork slides inside the selector so I don't see how it can rub anything...
 

hvyman

Dang Dude! No Way Man.
Staff member
Super Moderator
Authorized Seller
Joined
Apr 17, 2007
Messages
12,760
Location
Tokyo,jp
Who rebuilt it?
 

hvyman

Dang Dude! No Way Man.
Staff member
Super Moderator
Authorized Seller
Joined
Apr 17, 2007
Messages
12,760
Location
Tokyo,jp
As far as what?

The forks shouldn't touch any sort of gearing. If it does something is wrong. The Marlin crawler pieces and dm pieces are all well built and good.
 

emericaskater285

Badass
Authorized Seller
Joined
Sep 19, 2011
Messages
518
Location
Des Moines, IA
Never once had an issue with any of the "built" parts from DM or marlin. Ive built a couple myself, and have had many built r154's in and out of here.

is this a supra shop or something else?
 

dumbo

Supramania Contributor
Authorized Seller
Contributor
Joined
Jul 16, 2008
Messages
1,911
Location
Albera, Too Far North
Wow mine just did something very similar. 500km on rebuilt by a trans shop. Broke the thrust washer in two also.
 

gsxr141

Active Member
Authorized Seller
Joined
Oct 24, 2010
Messages
1,162
Location
rochester
hate to bring up an old thread, but I just had a similar problem........
had my trans rebuilt with all new parts from dm/mc.
the trans made a slight squealing noise a few times within 100 miles.
at about 225 miles it popped out of 2nd gear 3 times in about 3 hours.
finally, I couldn't get 3rd gear at about 3500rpm. made a loud squealing noise and would not go into gear.
I ended up driving it home with no issues. ????
the next morning I tried to start the car in neutral, and it lurched forward like it was in gear.. wtf? tried it many times and it did the same thing

after the rebuild, the trans seemed hard to get into gear, and was a little whiny.
i'm leaning towards a bad part ir bad rebuild.....
people are saying it was the mt90 or my beech short shifter.
while the car did lay down 800 wheel, I DID NOT beat on it at all. no fast shifting and no shifting anywhere near redline.