oil pump drive shaft, broken?

3.0 GT

2JZ Holset Mafia
Authorized Seller
Joined
Nov 30, 2008
Messages
381
Location
Franklin, Tn
i have a built 7mgte. i was driving today and i noticed an oil leak coming from the front of the block. so it took off the pully and front timing cover to find that the oil pump driveshaft is out of place. it is too close to the block and the timming belt was half on half off the pully. so i took the belt off and i can physically move the driveshaft in and out about 1/2 an inch. wtf would cause this and how do i fix it. the oil was leaking because the part of the shaft that goes in the seal was to far into the block and not touching the seal. i will post a video later. thanks!
 

hvyman

Dang Dude! No Way Man.
Staff member
Super Moderator
Authorized Seller
Joined
Apr 17, 2007
Messages
12,768
Location
Tokyo,jp
Its happened a few times to some. If you search you can find the carnage.

Could be a oiling issue.

Will have to pull head and reseal oil pan. Bustyz.
 

3.0 GT

2JZ Holset Mafia
Authorized Seller
Joined
Nov 30, 2008
Messages
381
Location
Franklin, Tn
ok thanks for all the replies. well i went ahead and took out the ds. i pulled the front plate off the engine to remove it and what do you know the shaft bearing surface was sheared away:: angry ::. i included some pics of it too. so is the peice that is broken $15 from toyota? if so great! and what do i do to ensure this WONT EVER HAPPEN again? thanks

sorry for shitty phone pics
 

Attachments

3.0 GT

2JZ Holset Mafia
Authorized Seller
Joined
Nov 30, 2008
Messages
381
Location
Franklin, Tn
well i bought a new collar and plate for about $35 at my local toyota. but is there anyway i can ensure this will never happen again?