Bird Cage light

TRC

New Member
Authorized Seller
Joined
Jul 30, 2015
Messages
6
Location
Portugal
Hi guys , i am having this issue whit the light since i have the car...I already changed the gasket MLS now and ARP ....but everytime i push car on the road the light comes on ...when i drive slow there his no light....i have fluid in the reservoir and the car his always at the normal temp....i have taken the reservoir off but i cant see any sensor.

Any help would be apreciated.
 

suprarx7nut

YotaMD.com author
Authorized Seller
Joined
Nov 10, 2006
Messages
4,130
Location
Arizona
There is a float sensor in the white/ivory reservoir. When that float isn't floating, it triggers the light. If your reservoir is really full and it still sets off the light, maybe your sensor is bad.
 
  • Like
Reactions: debrucer

plaaya69

86.5 Turbo Converted Supra
Authorized Seller
Contributor
Joined
Nov 18, 2006
Messages
1,502
Location
Lake County, IL
Hi guys , i am having this issue whit the light since i have the car...I already changed the gasket MLS now and ARP ....but everytime i push car on the road the light comes on ...when i drive slow there his no light....i have fluid in the reservoir and the car his always at the normal temp....i have taken the reservoir off but i cant see any sensor.

Any help would be apreciated.
I had that float sensor located on the bottom stick on mine when I first got my Supra as the reservoir was filled with gunk and old coolant inside it. I took the whole reservoir off and cleaned it out with some hot water, engine degreaser and used a baby bottle cleaning brush to make it look new again.

Dose your reservoir have gunk in it or possible oil residue?
 
  • Like
Reactions: cinderMK3

Asterix

Lurker of Power
Authorized Seller
Joined
Mar 31, 2005
Messages
502
Location
Vienna, VA
If your birdcage doesn't flash when you take a corner, you're not going fast enough.

Seriously, the fluid sloshes around. I can just about tell how much fluid I have by how much the light flashes while cornering.
 
  • Like
Reactions: debrucer and loc182

TRC

New Member
Authorized Seller
Joined
Jul 30, 2015
Messages
6
Location
Portugal
I had that float sensor located on the bottom stick on mine when I first got my Supra as the reservoir was filled with gunk and old coolant inside it. I took the whole reservoir off and cleaned it out with some hot water, engine degreaser and used a baby bottle cleaning brush to make it look new again.

Dose your reservoir have gunk in it or possible oil residue?
I did clean my reservoir and i couldnt see any sensor in it....the light only flash when i go fast like in 4th or 5th gear in a straight line....its just weird
 

GC89

BoostRodeo
Authorized Seller
Contributor
Joined
Jun 13, 2007
Messages
1,043
Location
Spokane, WA
stop driving like a jackass and upsetting the bird........