1988 N/A shell with 2JZ NA-T and 7m Electronics

dunnbeetle

Member
Authorized Seller
Joined
Dec 11, 2005
Messages
121
Likes
0
Location
Bemidji, MN
#1
Hi, I've been working on this car off and on for the past few years with no luck.

Mods:
-1988 na supra shell with 2JZ NA-T
-7MGTE electronics
-Map-Ecu 1
-IS300 Coils wired to 7M igniter
-Innovate LC-1 wideband controller
-Walbro 450lph fuel pump
-Had 1000cc injectors(e-85) but now has 550cc(pump gas)
-AFM delete(2.2k ohm resister in pins 1 and 2 of afm connector w/mapecu)

A few years back I had the car idling(roughly) on the above setup with the 1000cc and e-85. At the time I lived 4 hours away from where the car was stored and was crunched on time. When we had it running we noticed a oil leak so we put it in the garage and I wasn't able to touch it for a while. Next time I was able to work on the car(few months later), it would not start. As I said, this was a few years ago...I became busy with work and life so I haven't had much time to figure it out.

Here is when it was running: https://photos.app.goo.gl/y7jTAf5R7LoFI6bC3

Since then, I changed the injectors to RC 550's and put pump gas in to try to get it going. I have worked on it here and there and this has been what I have figured out so far:
-Fuel is getting to the injectors at least.
-Compression is good
-At least 2 of the plugs are getting spark(only checked 2)
-Car will fire when starting fluid is being sprayed in the intake

Today I disconnected the map-ecu and hooked the oem o2 wire back up and attempted to start the car with the afm and stock ecu and had no luck. I was able to get the car to fire a bit when my brother was messing with the cps while I was cranking. I double checked physical timing and that looks good. Also, I reset the position of the cps while the engine was at TDC, multiple times. Not sure if there is a gremlin in the wiring somewhere or if the cps is bad. I hard-wired the CPS after all this thinking maybe the plug was causing the issue, but still no luck.

I have checked the grounds by the intake and they are fine. I am also getting code 32 right away when I turn the key, even after a reset. It's possible the afm is bad, but it was fine when I used it last(a few years ago).

I don't have a ton of time to work on this, but any suggestions would be appreciated. Thanks.