Search results

  1. M

    Engine Code 24 - Intake Air Temperature Sensor (IAT)

    im getting this code, but quite honestly dont know where the sensor is located or if we actually have one at all. (1989 7mGTE). Anyone know what it could be? im also getting code 31.
  2. M

    Fuel cut? 7mgte

    im at work right now, just saw this, and i think you might have just solved my problem man! thank you in advance ( whether it works or not lol). ill let you now how it goes
  3. M

    Fuel cut? 7mgte

    not really, im trying to figure out how to upload a video but theyre all too long. only code are 31 & 51. 31 being a maf sensor code and 51 being open switch code
  4. M

    Fuel cut? 7mgte

    So the engine was running awfully. when driven on the road, the speedometer was not working. i could not go past 2k rpm, and it was simply an awful experience. got to my house and jacked the car up. i revved it up slowly and it would shift through gears and everything. catch is that when it...
  5. M

    Stalling when revved

    every diagram i found was the same, i replicated that, the only thing where i mightve messed up is by mixing up the brown wires
  6. M

    Stalling when revved

    check engine light is on, i ran it and got codes 31 and 51
  7. M

    Stalling when revved

    doesnt seem to be loosing oil, but there is definetlly oil/gas in exhaust. might not be a turbo leak, but i notice a leak coming from the right side, cant identify where it is exactly
  8. M

    Stalling when revved

    i went to an auto parts store and bought a MAF cleaner... i learned my lesson
  9. M

    Stalling when revved

    thats what i realized afterwards, i was replacing the sensor anyways so i wanted to see if it would mess up the sensor completely. i installed the new one and its stll happening
  10. M

    Stalling when revved

    i disconnected it, tried to recalibrate, ended up buying a new tps from toyota and its still happening
  11. M

    Stalling when revved

    I took out my VAF/MAF sensor to clean it (with the right cleaner), when i went to plug it back in, the car wouldnt start. i realize my wiring on my sensor was loose so i rewired. The car now starts and has a fairly good idle, but when revved up engine stalls out. If accelerated at a constant...